aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVidhu Kant Sharma <vidhukant@vidhukant.com>2023-08-30 01:06:39 +0530
committerVidhu Kant Sharma <vidhukant@vidhukant.com>2023-08-30 01:06:39 +0530
commit2fdcb7c79e8333c0fa9c14e34da5eaebe96e32b4 (patch)
tree919a0065276553b16c930885312008d2574fe114 /Cargo.toml
first commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..0aecc15
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "openbills-web"
+version = "0.0.1"
+edition = "2021"
+description = "Web client for Libre Billing Software"
+readme = "README.md"
+repository = "https://dev.vidhukant.xyz/openbills-web"
+license = "GNU GPL V3"
+keywords = ["yew", "openbills", "invoicing-software", "billing-software"]
+categories = ["gui", "wasm", "web-programming"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[dependencies]
+yew = { version="0.20", features=["csr"] }
+yew_icons = { version = "0.7", features = [ "FontAwesomeSolidCartShopping", "FontAwesomeSolidUser", "FontAwesomeSolidIndustry", "FontAwesomeSolidFileInvoice", "FontAwesomeSolidHouseChimney", "FontAwesomeSolidGear", "FontAwesomeSolidPlus", "FontAwesomeSolidMagnifyingGlass", "FontAwesomeSolidMountainSun" ] }
+
+yew-router = "0.17"
+